Windows10 Native 설치

필요 환경 설치

● Python 2.7 : https://www.python.org/downloads/release/python-2716/ (32bit)

● Microsoft Visual C++ Compiler for Python 2.7 :
https://www.microsoft.com/en-us/download/details.aspx?id=44266

● Git for Windows : https://git-scm.com/download/win (64bit)

설치

Windows키 + R cmd 입력 후 실행

실행

매번 cmd 창에서 실행하기 번거로우니 원하는 곳에 batch 파일 생성.
바탕화면에 sjva.bat 로 파일 생성 후 아래 코드를 각자 자신의 경로에 맞게 변경한 후 저장한 후 더블클릭 하면 실행됩니다.

예) 경로가 C:\Users\soju6\SJVA 인 경우

주의)복사시 &amp ; 는 &으로 변경해주세요

cmd 창 없이 실행

sjva.vbs 파일 생성하여 sjva.bat 파일 경로 입력.
예) sjva.bat 파일을 바탕화면에 생성한 경우

시작프로그램 등록

Window키 + R에 shell:startup 입력 후
sjva.bat 파일 혹은 sjva.vbs 파일 복사.

Hits: 2062

This Post Has 23 Comments

  1. 동영상까지 올려주셨네요. 감사합니다. 도커 윈도우 썼었는데, 네이티브로 옮겨타야겠네요.

  2. 좋은자료 감사합니다
    저는전부설치후 cmd에서 첫번째문구 쓰면(install)
    python -m pip install –upgrade pip
    명령어로 설치하려는데 빨간글씨로 에러가나네요..
    마지막에 노란글씨로
    you are using pip version 18.1 , however version 19.22 is available.
    ……………………….–upgrade pip’ command
    해결방법이있을까요?

    1. 그냥 넘어가셔도 됩니다

  3. 아래 오류입니다 cmd창복사했습니다
    제컴퓨터가 문제가 있는것일까요?.. 1시간째 이리저리해도 안되네요…

    Microsoft Windows [Version 10.0.18362.295]
    (c) 2019 Microsoft Corporation. All rights reserved.

    C:\Users\최인용>python -m pip install –upgrade pip
    Collecting pip
    Exception:
    Traceback (most recent call last):
    File “C:\Python27\lib\site-packages\pip\_internal\cli\base_command.py”, line 143, in main
    status = self.run(options, args)
    File “C:\Python27\lib\site-packages\pip\_internal\commands\install.py”, line 318, in run
    resolver.resolve(requirement_set)
    File “C:\Python27\lib\site-packages\pip\_internal\resolve.py”, line 102, in resolve
    self._resolve_one(requirement_set, req)
    File “C:\Python27\lib\site-packages\pip\_internal\resolve.py”, line 256, in _resolve_one
    abstract_dist = self._get_abstract_dist_for(req_to_install)
    File “C:\Python27\lib\site-packages\pip\_internal\resolve.py”, line 209, in _get_abstract_dist_for
    self.require_hashes
    File “C:\Python27\lib\site-packages\pip\_internal\operations\prepare.py”, line 283, in prepare_linked_requirement
    progress_bar=self.progress_bar
    File “C:\Python27\lib\site-packages\pip\_internal\download.py”, line 836, in unpack_url
    progress_bar=progress_bar
    File “C:\Python27\lib\site-packages\pip\_internal\download.py”, line 673, in unpack_http_url
    progress_bar)
    File “C:\Python27\lib\site-packages\pip\_internal\download.py”, line 895, in _download_http_url
    file_path = os.path.join(temp_dir, filename)
    File “C:\Python27\lib\ntpath.py”, line 85, in join
    result_path = result_path + p_path
    UnicodeDecodeError: ‘ascii’ codec can’t decode byte 0xc3 in position 7: ordinal not in range(128)
    You are using pip version 18.1, however version 19.2.2 is available.
    You should consider upgrading via the ‘python -m pip install –upgrade pip’ command.

    C:\Users\최인용>
    C:\Users\최인용>pip install –upgrade setuptools
    Collecting setuptools
    Exception:
    Traceback (most recent call last):
    File “c:\python27\lib\site-packages\pip\_internal\cli\base_command.py”, line 143, in main
    status = self.run(options, args)
    File “c:\python27\lib\site-packages\pip\_internal\commands\install.py”, line 318, in run
    resolver.resolve(requirement_set)
    File “c:\python27\lib\site-packages\pip\_internal\resolve.py”, line 102, in resolve
    self._resolve_one(requirement_set, req)
    File “c:\python27\lib\site-packages\pip\_internal\resolve.py”, line 256, in _resolve_one
    abstract_dist = self._get_abstract_dist_for(req_to_install)
    File “c:\python27\lib\site-packages\pip\_internal\resolve.py”, line 209, in _get_abstract_dist_for
    self.require_hashes
    File “c:\python27\lib\site-packages\pip\_internal\operations\prepare.py”, line 283, in prepare_linked_requirement
    progress_bar=self.progress_bar
    File “c:\python27\lib\site-packages\pip\_internal\download.py”, line 836, in unpack_url
    progress_bar=progress_bar
    File “c:\python27\lib\site-packages\pip\_internal\download.py”, line 673, in unpack_http_url
    progress_bar)
    File “c:\python27\lib\site-packages\pip\_internal\download.py”, line 895, in _download_http_url
    file_path = os.path.join(temp_dir, filename)
    File “c:\python27\lib\ntpath.py”, line 85, in join
    result_path = result_path + p_path
    UnicodeDecodeError: ‘ascii’ codec can’t decode byte 0xc3 in position 7: ordinal not in range(128)
    You are using pip version 18.1, however version 19.2.2 is available.
    You should consider upgrading via the ‘python -m pip install –upgrade pip’ command.

    C:\Users\최인용>pip install virtualenv
    Collecting virtualenv
    Exception:
    Traceback (most recent call last):
    File “c:\python27\lib\site-packages\pip\_internal\cli\base_command.py”, line 143, in main
    status = self.run(options, args)
    File “c:\python27\lib\site-packages\pip\_internal\commands\install.py”, line 318, in run
    resolver.resolve(requirement_set)
    File “c:\python27\lib\site-packages\pip\_internal\resolve.py”, line 102, in resolve
    self._resolve_one(requirement_set, req)
    File “c:\python27\lib\site-packages\pip\_internal\resolve.py”, line 256, in _resolve_one
    abstract_dist = self._get_abstract_dist_for(req_to_install)
    File “c:\python27\lib\site-packages\pip\_internal\resolve.py”, line 209, in _get_abstract_dist_for
    self.require_hashes
    File “c:\python27\lib\site-packages\pip\_internal\operations\prepare.py”, line 283, in prepare_linked_requirement
    progress_bar=self.progress_bar
    File “c:\python27\lib\site-packages\pip\_internal\download.py”, line 836, in unpack_url
    progress_bar=progress_bar
    File “c:\python27\lib\site-packages\pip\_internal\download.py”, line 673, in unpack_http_url
    progress_bar)
    File “c:\python27\lib\site-packages\pip\_internal\download.py”, line 895, in _download_http_url
    file_path = os.path.join(temp_dir, filename)
    File “c:\python27\lib\ntpath.py”, line 85, in join
    result_path = result_path + p_path
    UnicodeDecodeError: ‘ascii’ codec can’t decode byte 0xc3 in position 7: ordinal not in range(128)
    You are using pip version 18.1, however version 19.2.2 is available.
    You should consider upgrading via the ‘python -m pip install –upgrade pip’ command.

    C:\Users\최인용>git clone https://github.com/soju6jan/SJVA.git
    fatal: destination path ‘SJVA’ already exists and is not an empty directory.

    C:\Users\최인용>

    1. 싹다 지우고 하세요.. 한글들어간 폴더 에서 하지 마시구요.
      동영상까지 올렸고, 그대로 했는데 안되면 도와드릴 방법은 없어요.
      포맷하고 다시 설치하시던지, 티빙 때문이라면 다른사람에게 부탁해서 쓰시는게 나을겁니다.

  4. 소주6잔님 안녕하세요.
    우연한 기회에 소주6잔님의 POOQ, OKSUSU, TVING 애드온을 접하면서 KODI를 알게 되었습니다.
    TVING을 SJVA URL 및 TOKEN을 입력해야 볼수 있다고 하셔서 문의글 남깁니다.

    공유기에 SJVA를 설치를 할 수 없는지요?
    사용 제품은 IPTIME A5004NS + 1T 외장하드를 연결 후 NAS로 활용 중입니다.

    바쁘시겠지만 댓글 보시면 답변 좀 부탁 드리겠습니다.

  5. 소주6잔님 덕분에 잘쓰고 있습니다 궁금한게 한가지 있어서 질문드리고자합니다
    혹시 네이티브 설치시에 d:까지 인식가능하게 하려면 위 설치 과정중 어느부분에서 추가 명령어를 입력해야할까요?
    그리고 추가 명령어는 -v 명령으로 하는게 맞는지도 궁금합니다

    1. 네이티브면 당연히 D 드라이브 자동적(?)으로 인식합니다. 멀 해주고 말게 없습니다.
      다만 파일매니저에서는 안보입니다. 그냥 경로 쓰시면 인식됩니다.
      예) Z:\download/synotest

  6. 말씀하신거처럼 파일 매니저에서 안보이길래 혹시나 따로 해줘야되나했네요 감사합니다

  7. 맥에서도 사용 할 수 있도록 해주세요 ㅠ
    너무 사용 하고 싶은데.. 방법이 없네요.

    1. 루나님 안녕하세요. 맥이 없어서 테스트를 못하고 있습니다. ssh 접속만 하게 해주시면 설치해보겠습니다.

      1. 우앗 정말요? 준비 되는대로 연락 쪽지 남겨 놓을 게요!!! 고마워요 소주6잔님!!!

  8. 감사하고 수고많으십니다. 설명대로 설치하는데 에러가 나서 문의좀 드립니다
    아래 내용이고 원인이 뭔가 알수있을까요? 지웠다 다시깔아봐도 안되네요 …

    Error: While importing “sjva”, an ImportError was raised:

    Traceback (most recent call last):
    File “C:\Users\sh\SJVA\venv\lib\site-packages\flask\cli.py”, line 235, in locate_app
    __import__(module_name)
    File “C:\Users\sh\SJVA\sjva.py”, line 66, in
    import framework
    File “d:\SJVA\lib\framework\__init__.py”, line 24, in
    File “D:\Cloud\CloudStation\SJ\SJVA\lib\framework\class_scheduler.py”, line 14, in
    File “C:\Users\sh\SJVA\venv\lib\site-packages\apscheduler\schedulers\gevent.py”, line 11, in
    raise ImportError(‘GeventScheduler requires gevent installed’)
    ImportError: GeventScheduler requires gevent installed

  9. 제일 처음 python upgrade에서 오류가 나는것은 한글 계정으로 python을 설치해서 그런것 같습니다.
    아래 블로그대로 했더니 정상적으로 됩니다. 참고하세요.
    https://blog.naver.com/pjok1122/221588966556

    1. 정보 감사합니다.

  10. 설치는 잘됐는데요..
    site.db가 없다고 나오네요… site.db file ot exist

    1. 아 그냥 제대로 다시 하니까 넘어가네요… activate 가 안먹었던거 같습니다 ^^;

  11. my_start.bat 실행시 로컬호스트로 접속하였는데 접속이 안되어 재부팅후 다시 실행하니 아래 로그가 반복해서 무한출력되는 증상이 있었습니다.

    포트포워딩 후 설치 명령어 처음부터 모두 다시 입력하니 정상 접속됩니다.

    참고하세요

    –반복
    HEAD is now at 27e3524 1
    Already up to date.
    DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
    Requirement already satisfied: youtube-dl==2019.5.11 in c:\python27\lib\site-packages (from -r .\update_requirements.txt (line 1)) (2019.5.11)
    Requirement already satisfied: telepot==12.7 in c:\python27\lib\site-packages (from -r .\update_requirements.txt (line 2)) (12.7)
    Requirement already satisfied: transmissionrpc==0.11 in c:\python27\lib\site-packages (from -r .\update_requirements.txt (line 3)) (0.11)
    Requirement already satisfied: synolopy==0.1.2 in c:\python27\lib\site-packages (from -r .\update_requirements.txt (line 4)) (0.1.2)
    Requirement already satisfied: guessit==3.0.4 in c:\python27\lib\site-packages (from -r .\update_requirements.txt (line 5)) (3.0.4)
    Requirement already satisfied: urllib3>=1.9.1 in c:\python27\lib\site-packages (from telepot==12.7->-r .\update_requirements.txt (line 2)) (1.25.6)
    Requirement already satisfied: six>=1.1.0 in c:\python27\lib\site-packages (from transmissionrpc==0.11->-r .\update_requirements.txt (line 3)) (1.12.0)
    Requirement already satisfied: python-dateutil in c:\python27\lib\site-packages (from guessit==3.0.4->-r .\update_requirements.txt (line 5)) (2.8.0)
    Requirement already satisfied: rebulk in c:\python27\lib\site-packages (from guessit==3.0.4->-r .\update_requirements.txt (line 5)) (2.0.0)
    Requirement already satisfied: babelfish in c:\python27\lib\site-packages (from guessit==3.0.4->-r .\update_requirements.txt (line 5)) (0.5.5)
    C:\Python27\python.exe: No module named flask
    not monkey
    C:\Users\HomeServer KJ\SJVA\data\db\site.db
    site.db file exist!!
    Traceback (most recent call last):
    File “sjva.py”, line 66, in
    import framework
    File “D:\SJVA\lib\framework\__init__.py”, line 14, in
    ImportError: No module named flask
    PYTHON EXIT CODE : 1…………..
    REPEAT….

  12. 무한 반복되고 있습니다 포트포워딩에 대해 자세히 알려주실수 있으신가요?

  13. 설명대로 그대로 했는데
    [Errno 10048] 각 소켓 주소(프로토콜/네트워크 주소/포트): (‘0.0.0.0’, 9999)
    [Errno 10048] 각 소켓 주소(프로토콜/네트워크 주소/포트): (‘0.0.0.0’, 9999)
    이부분이 에러가 뜨네요…

  14. [Errno 10048] 각 소켓 주소(프로토콜/네트워크 주소/포트): (‘0.0.0.0’, 9999)
    [Errno 10048] 각 소켓 주소(프로토콜/네트워크 주소/포트): (‘0.0.0.0’, 9999)
    [Errno 10048] 각 소켓 주소(프로토콜/네트워크 주소/포트): (‘0.0.0.0’, 9999)
    [2019-10-10 17:15:34,759|DEBUG|base.py:940] Looking for jobs to run
    [2019-10-10 17:15:34,760|DEBUG|base.py:1020] Next wakeup is due at 2019-10-10 17:17:42.759000+09:00 (in 127.998000 seconds)
    [2019-10-10 17:15:34,762|INFO|base.py:123] Running job “Job.job_function (trigger: interval[0:02:08], next run at: 2019-10-10 17:17:42 KST)” (scheduled at 2019-10-10 17:15:34.759000+09:00)
    [2019-10-10 17:15:34,763|WARNING|class_scheduler.py:64] XX first_run_check_thread_function
    [2019-10-10 17:15:34,763|INFO|base.py:627] Removed job scheduler_check
    [2019-10-10 17:15:34,765|DEBUG|class_scheduler.py:136] remove job_id:scheduler_check
    [2019-10-10 17:15:34,765|WARNING|class_scheduler.py:86] first_run_check_thread_function end!!
    [2019-10-10 17:15:34,766|DEBUG|class_scheduler.py:127] job_id:scheduler_check None
    [2019-10-10 17:15:34,766|DEBUG|class_scheduler.py:163] remove_job_instance : scheduler_check
    [2019-10-10 17:15:34,767|INFO|base.py:144] Job “Job.job_function (trigger: interval[0:02:08], next run at: 2019-10-10 17:17:42 KST)” executed successfully

  15. 시놀로지 도커 -> 윈도우 도커 -> 윈도우 네이티브 모두 설치했는데요
    시놀로지는 218+라서 리소스가 부족해서 윈도우에 도커를 설치했습니다.
    윈도우 도커도 좋은데, 윈도우 네이티브가 더 가볍더라구요..

    윗분들 댓글처럼
    0,0,0,0 증상 및 무한반복 증상이 있었는데,
    리부팅후 재설치하니 아주아주 잘 설치되었습니다.

    좋은 프로그램 만들어주신 소주6잔님께 감사의 말씀을 드립니다.

  16. 윈도우 서버 2016에서도 잘 됩니다. 좋은 프로그램 만들어주셔서 감사합니다. Kodi 애드온들도 정말 잘 쓰고 있습니다.

댓글 남기기

Close Menu